HDU1043:Eigth(康托展开)

 

Problem Description

 

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:  
 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:  
 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.  

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and  
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).  

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three  
arrangement.
 


 

Input

 

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle  

1 2 3  
x 4 6  
7 5 8  

is described by this list:  

1 2 3 x 4 6 7 5 8
 


 

Output

 

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
 


 

Sample Input

 

  
  
2 3 4 1 5 x 7 6 8
 


 

Sample Output

 

ullddrurdllurdruldr
 
8数码问题网上解说很多,我是用康托展开做的
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;

int s[20],pos[20],end[20];
int hash[20],vis[1000000];
string ans[1000000];

struct node
{
    string step;
    int num[10],val;
    int pp;
};

int solve(int s[])
{
    int sum=0;
    for(int i=0; i<9; i++)
    {
        int num=0;
        for(int j=i+1; j<9; j++)
            if(s[j]<s[i])num++;
        sum+=(num*hash[9-i-1]);
    }
    return sum+1;
}

int to[4][2] = {{-1,0},{1,0},{0,-1},{0,1}};
char path[10] = "durl";

void bfs()
{
    memset(vis,0,sizeof(vis));
    int i,j;
    node a,next;
    queue<node> Q;
    for(i = 0; i<8; i++)
        a.num[i] = i+1;
    a.num[8] = 0;
    a.pp = 8;
    a.step = "";
     a.val = 46234;
    ans[a.val] = "";
    Q.push(a);
    while(!Q.empty())
    {
        a = Q.front();
        Q.pop();
        int x = a.pp/3;
        int y = a.pp%3;
        for(i = 0; i<4; i++)
        {
            int tx = x+to[i][0];
            int ty = y+to[i][1];
            if(tx<0 || ty<0 || tx>2 || ty>2)
                continue;
            next = a;
            next.pp = 3*tx+ty;
            next.num[a.pp] = next.num[next.pp];
            next.num[next.pp] = 0;
            next.val = solve(next.num);
            if(!vis[next.val])
            {
                vis[next.val]=true;
                next.step=path[i]+next.step;
                Q.push(next);
                ans[next.val]=next.step;
            }
        }
    }
}

int main()
{
    int i;
    char ch;
    node a;
    int c[10];
    hash[0] = 1;
    for(i = 1; i<=10; i++)
        hash[i] = hash[i-1]*i;
    bfs();
    while(cin >> ch)
    {
        if(ch == 'x')
            c[0] = 0;
        else c[0]=ch-'0';
        for(int i=1; i<9; i++)
        {
            cin>>ch;
            if(ch=='x')
                c[i]=0;
            else c[i]=ch-'0';
        }
        int k;
        k = solve(c);
        if(vis[k])
            cout << ans[k] << endl;
        else
            cout << "unsolvable" << endl;

    }

    return 0;
}


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值