Just A Triangle

Problem Description
  This is an easy problem, just for you to warm up.
  Give you three edges of a triangle. Can you tell me which kind of triangle it stands for?
If it’s a right triangle(直角三角形), please output “good”. If it’s a isosceles triangle(等腰三角形), please output “perfect”. Otherwise, please output “just a triangle”. You may suppose the input is legal.
 
Input
The first line contains an integer t means the number of test cases.
The each case contains three integers a, b, c in a line which stands for the length of the three edges.
(0 <a, b, c < 300).
 
Output
For each case, output the answer in one line.
 
Sample Input
4
3 4 5
2 2 3 
1 4 4
4 6 3
 
Sample Output
good
perfect
perfect
just a triangle
 
 
Source
HDU 2009-11 Programming Contest
 
Recommend
lcy
 
题目分析
判断三角形的类型,并按给定要求输出,直角三角形输出good,等腰三角形输出perfect,其他三角形输出just a triangle
解题思路
水题,判断一下就行
源代码
#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
//#include<bits\stdc++.h>
using namespace std;
void solve()
{
    vector<int>vec(3);
    cin>>vec[0]>>vec[1]>>vec[2];
    sort(vec.begin(),vec.end());
    if(vec[0]*vec[0]+vec[1]*vec[1]==vec[2]*vec[2])
        cout<<"good"<<endl;
   else
 if(vec[0]==vec[1]||vec[1]==vec[2])
  cout<<"perfect"<<endl;
 else
  cout<<"just a triangle"<<endl;
}
int main()

 int t;
 cin>>t;
 while(t--)
 {
      solve();
 }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值