hdu1098:Ignatius's puzzle

Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

 

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 

Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 

Sample Input
  
  
11 100 9999
 

Sample Output
  
  
22 no 43
 


题意就是给定k的值,求出最小的a,是的x为任何整数值时,方程的值总是能整除65

这是一道数学题

用数学归纳法

设f(x)能整除65

要证明f(x+1)能整除65的话就只需要证明f(x+1)-f(x)能整除65

用二项式分拆

因为常数是13的总能提出一个5的系数相乘,5的则能提出13相乘

所以前面的项必能被65整除,现在只许看后面的a*k了

所以最后只需证明18+a*k能否被65整除就行了

推出了这个就简单了

 

#include <stdio.h>

int main()
{
    int k,a;
    while(~scanf("%d",&k))
    {
        for(a = 1;a<=65;a++)
        {
            if((18+a*k)%65 == 0)
            {
                printf("%d\n",a);
                break;
            }
        }
        if(a>65)
        printf("no\n");
    }

    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值