HDU3346:Lucky Number

Problem Description
To Chinese people, 8 is a lucky number. Now your task is to judge if a number is lucky.
We say a number is lucky if it’s a multiple of 8, or the sum of digits that make up the number is a multiple of 8, or the sum of every digit’s square is a multiple of 8.
 

Input
The first line contains an integer stands for the number of test cases.
Each test case contains an integer n (n >= 0).
 

Output
For each case, output “Lucky number!” if the number is lucky, otherwise output “What a pity!”.
 

Sample Input
  
  
2 0 8
 

Sample Output
  
  
Lucky number! Lucky number!
 


 

一开始没有注意到每个数字的平方数的和

 

#include <stdio.h>

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int a,flag = 0,sum1 = 0,sum2 = 0;
        scanf("%d",&a);
        if(a%8 == 0)
            flag = 1;
        else
        {
            while(a)
            {
                sum1+=a%10;
                sum2+=(a%10)*(a%10);
                a/=10;
            }
            if(sum1%8 == 0)
                flag = 1;
            else if(sum2%8 == 0)
                flag = 1;
        }
        if(flag)
            printf("Lucky number!\n");
        else
            printf("What a pity!\n");
    }

    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值