HDU 1719 Friend 【数学题】

45 篇文章 0 订阅
12 篇文章 0 订阅

 

 

Friend

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2005    Accepted Submission(s): 1009


Problem Description

 

Friend number are defined recursively as follows.
(1) numbers 1 and 2 are friend number;
(2) if a and b are friend numbers, so is ab+a+b;
(3) only the numbers defined in (1) and (2) are friend number.
Now your task is to judge whether an integer is a friend number.
 


 

Input

 

There are several lines in input, each line has a nunnegative integer a, 0<=a<=2^30.
 


 

Output

 

For the number a on each line of the input, if a is a friend number, output “YES!”, otherwise output “NO!”.
 


 

Sample Input

 

  
  
3 13121 12131
 


 

Sample Output

 

  
  
YES! YES! NO!
 


 

Source

 

 


 

第一次写硬是没有写出来,一直以为是打表写的,发现也没啥规律可循的,唯一找出来是一个递推方程,可是感觉太麻烦,不想写。后来看了别人写的,感觉自己在数学方面还是有点欠缺的,所以有必要解释解释,给自己看。

 

首先,原式ab+a+b = ab+a+b+1-1 = (a+1)*(b+1)-1

令a = (a1+1)*(a2+1)-1;

b = (b1+1)*(b2+1)-1;

代入原式中可得:n = (a1+1)*(b1+1)*(a2+1)*(b2+1)-1;

因为原式的朋友数都是由1,2推到出来的

所以递推到最底层,那么(a1+1)*(b1+1)*(a2+1)*(b2+1)肯定是2,3的倍数(即是1+1,2+1)

所以最后就是要解决n+1得到的数到底是不是只有2,3这些因子

 

#include<stdio.h>
int main()
{
	int x,y,a;
	while(~scanf("%d",&a))
	{
		if(a==0)
		{
			printf("NO!\n");
			continue;
		}
		else
		{
			a=a+1;
			while(a%2==0||a%3==0)
			{
				if(a%2==0)
					a/=2;
				else if(a%3==0)
					a/=3;
			}
		}
		if(a==1)
			printf("YES!\n");
		else
			printf("NO!\n");
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值