HDU 1396 Counting Triangles

Counting Triangles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2565    Accepted Submission(s): 1204


Problem Description
Given an equilateral triangle with n the length of its side, program to count how many triangles in it.



 

Input
The length n (n <= 500) of the equilateral triangle's side, one per line.

process to the end of the file
 

Output
The number of triangles in the equilateral triangle, one per line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 5 13
 

Author
JIANG, Jiefeng
 

Source
 

 

注意:

1:找规律

2:正三角形与倒的三角形的规律

#include<stdio.h>
int main (void)
{
    int f[505]= {0},n,a;
    f[1]=1;
    f[2]=5;
    f[3]=13;
    f[4]=27;
    f[5]=48;
    for(n=6; n<=500; n++)
    {
        if(n%2==0)
        {
            f[n]=f[n-1]+(2*n-1)+(n*n-n)/2+(n*n-4*n+4)/4;
        }//+(2*n-1)+(n*n-n)/2是正三角的增加规律
        //(n*n-4*n+4)/4是倒三角形的增加规律
        if(n%2==1)
        {
            f[n]=f[n-1]+(2*n-1)+(n*n-n)/2+(n*n-4*n+3)/4;
        }//(n*n-4*n+3)/4是n%2==1时倒三角的增加规律
    }
    while(~scanf("%d",&a))
    {
        printf("%d\n",f[a]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值