1097. LED Modding

Sample Input

5 3 20 2
Red 90
Orange 110
5 3 20 2
ThisOne 110
TheOtherOne 100
5 3 20 1
TooLittle 90
5 5 20 1
Sample 10

Sample Output

100.00 Orange
100.00 TheOtherOne
impossible
“—”

#include<iostream>
#include<vector>
#include<cstring>
#include<iomanip>
#include<algorithm>
using namespace std;

class resistance {
    public:
        string name;
        int r;
};


bool cmp(resistance one, resistance another) {
    if (one.r < another.r) return true;
    else return false;
}

int main() {
    resistance arr[10000];
    string str;
    double result;
    int tempr;
    //  totalvol位总电压,vol为电压,cur为电流 
    //  保证电路正常所需要接入的最小电阻 
    int totalvol, vol, cur, n;
    while (cin >> totalvol >> vol >> cur >> n) {
        bool flag = false;
        if (totalvol <= 0) {
            cout << "IMPOSSIBLE" << endl;
            continue;
        }
        for (int i = 0; i < n; ++i) {
            cin >> arr[i].name >> arr[i].r;
        }
        result = 1000.0 * (totalvol - vol) / cur;  // 还能承载的最小电阻
        if (result <= 0) {
            cout << "---" << endl;
            continue;
        }
        sort(arr, arr + n, cmp);  //  重要,如果直接用冒泡排序的话很可能会超时,注意sort函数的使用,其中最后一个参数是回调函数,返回值是bool值
        for (int i = 0; i < n; ++i) {
            if (arr[i].r >= result) {
                cout.setf(ios::fixed);
                cout.precision(2);
                cout << result << " " << arr[i].name << endl;
                flag = false;
                break;
            }
        }
        if (flag) cout << "IMPOSSIBLE" << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值