PAT A1001 2019.07.07 【水题】

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 

思路分析

要求把sum按照固定格式输出

看输入量的限定可以知道,最大值不会超过2'000'000 ,也就是对应会有0个、1个或2个“ ' ”

那么只要直接判定最后属于哪种格式,然后输出即可

#include<iostream>  
#include<stdio.h>
using namespace std;
int main()  
{  
  int a,b;  
  int sum;  
  cin>>a>>b;
  sum = a+b;  
  
    if(sum < 0)
	{  
    cout<<"-";
    sum = -sum;  
    }  
    
    if(sum>=1000000)
	{  
        printf("%d,%03d,%03d",sum/1000000, (sum/1000)%1000, sum%1000);  
    }  
    
    else if(sum >= 1000)
	{  
        printf("%d,%03d",sum/1000,sum%1000);  
    } 
    
	else
	{  
        printf("%d", sum);  
    }  
 
  return 0;  
}  

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值