PAT A1150 2019.08.16 【自定义图判断】

1150 Travelling Salesman Problem (25 分)

The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C​1​​ C​2​​ ... C​n​​

where n is the number of cities in the list, and C​i​​'s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

思路分析

根据输入建立无向有权图

由于数据量很小,只有200,所以直接用定长二维数组建图即可

接下来就是相关判定,找环,计算路径消耗,期间用访问标志位进行辅助即可

最后可能判环条件出了问题,导致被扣4分,暂时未找到原因

//  21/25 
#include<cstdio>
#include<iostream>
#define MAX 210
using namespace std;

int city[MAX][MAX]={0};
int path[MAX]={0};
int haveCity[MAX]={0};
int visit[MAX]={0};
int n,m,k;

int main()
{
	scanf("%d %d",&n,&m);
	for(int i=0;i<m;i++)
	{
		int a,b,dis;
		scanf("%d %d %d",&a,&b,&dis);
		city[a][b]=dis;
		city[b][a]=dis;
		haveCity[a]=1;
		haveCity[b]=1;
	}
	
//	for(int i=0;i<MAX;i++)
//	{
//		if(haveCity[i]!=1)continue;
//		printf("\ncity %d:",i);
//		for(int j=0;j<MAX;j++)
//		{
//			if(city[i][j]!=0)
//			printf(" #%d(%d)",j,city[i][j]);
//		}	
//	}
//	printf("\n");

	scanf("%d",&k);
	int outIndex=1;
	int minDis=9999;
	for(int jj=1;jj<=k;jj++)
	{
		for(int i=0;i<MAX;i++)visit[i]=0;
		int isTsCycle=0;
		int isCycle=1;
		int allVisit=1;
		int vn;//vector Num
		int totalDis=0;
		if(vn<n+1)isTsCycle=0;
		scanf("%d",&vn);
		for(int i=1;i<=vn;i++)
		{
			scanf("%d",&path[i]);
			visit[path[i]]=1;
			if(i>1)
			{
				totalDis+=city[path[i]][path[i-1]];
				if(city[path[i]][path[i-1]]==0)
				  isCycle=0;
			}
		}
		
		for(int i=1;i<=n;i++)
		{
			if(visit[i]==0)allVisit=0;
		}
		
		if(isCycle==0)printf("Path %d: NA (Not a TS cycle)\n",jj);
		else
		{
			printf("Path %d: %d",jj,totalDis);
			if(allVisit==1&&vn==n+1&&path[1]==path[vn])
			{
				printf(" (TS simple cycle)\n");
				if(totalDis<minDis)
				{
					outIndex=jj;
					minDis=totalDis;
				}
				continue;
			}
			else if(allVisit==1&&vn>n+1&&path[1]==path[vn])
			{
				printf(" (TS cycle)\n");
				if(totalDis<minDis)
				{
			
					outIndex=jj;
					minDis=totalDis;
				}
				continue;
			}
			else printf(" (Not a TS cycle)\n");
		}
		


		  
	}
	printf("Shortest Dist(%d) = %d\n",outIndex,minDis);
	

} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值