HDU 6055 Regular polygon

Regular polygon

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1789 Accepted Submission(s): 702

Problem Description
On a two-dimensional plane, give you n integer points. Your task is to figure out how many different regular polygon these points can make.

Input
The input file consists of several test cases. Each case the first line is a numbers N (N <= 500). The next N lines ,each line contain two number Xi and Yi(-100 <= xi,yi <= 100), means the points’ position.(the data assures no two points share the same position.)

Output
For each case, output a number means how many different regular polygon these points can make.

Sample Input
4
0 0
0 1
1 0
1 1
6
0 0
0 1
1 0
1 1
2 0
2 1

Sample Output
1
2

题意:求能构成的正多边形的个数;但是由于输入的都是整数可知道构成的的一共都是正方形。
解题思路:先有两个点确定正方形的一条边,在有两点确定对角点,如果已知数据中同时存在两个对角点,即能形成正方形。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxx=510;
struct node
{
    int x,y;
    bool operator<(const node &text)const
    {
        if(x==text.x)
            return y<text.y;
        else
            return x<text.x;
    }
}nodes[maxx];
int main()
{
    int n;
    while(scanf("%d",&n)==1&&n)
    {
        int ans=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&nodes[i].x,&nodes[i].y);
        }
        sort(nodes,nodes+n);
        for(int i=0;i<n;i++)
        {
            for(int j=i+1;j<n;j++)
            {
                node tmp;
                tmp.x=nodes[i].x+nodes[i].y-nodes[j].y;
                tmp.y=nodes[i].y+nodes[j].x-nodes[i].x;
                if(!binary_search(nodes,nodes+n,tmp)) continue;
                tmp.x=nodes[j].x+nodes[i].y-nodes[j].y;
                tmp.y=nodes[j].y+nodes[j].x-nodes[i].x;
                if(!binary_search(nodes,nodes+n,tmp)) continue;
                ans++;
            }

        }
        printf("%d\n",ans/2);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值