HDU 6063 RXD and math(数学 )

这里写图片描述
Input
There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers n,k.

Output
For each test case, output “Case #x: y”, which means the test case number and the answer.

Sample Input
10 10

Sample Output
Case #1: 999999937

快速幂水过
注意取余


#include<cstdio>
using namespace std;
const int mod=1e9+7;
long long pow(long long a,long long n)
{
    long long text=1;
    while (n)
    {
        if (n&1) text = (text%mod)*(a%mod)%mod;
        a = (a%mod)*(a%mod)%mod;
        n >>= 1;
    }
    return text;
}
int main()
{
    long long n,k;
    int i=1;
    while(~scanf("%lld%lld",&n,&k))
    {
        long long text=pow(n,k);
        printf("Case #%d: %lld\n",i++,text);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值