B - Flip Game

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 

  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

题意:有一个棋盘,4*4的大小,有黑白两种棋子,在棋盘中翻动一个棋子这个棋子的四个方向都需要变动,问使全盘变为同一种颜色而翻动的棋子个数最少,输出翻动的子个数,如果不能使全盘变为同一种颜色,则输Impossible。

题解:直接暴力搜索,每个棋子都有两种情况。共有2^16种情况,每翻动一次,都需判断一下是否为同一个颜色。

 

#include<stdio.h>
int min(int a,int b)
{
    return a<b?a:b;
}
char map[20][20];
int nextt[4][2]={0,1,0,-1,-1,0,1,0},min1;
int F()
{
    for(int i=0;i<4;i++)
        for(int j=0;j<4;j++)
        if(map[i][j]!=map[0][0])
        return 0;
    return 1;
}
void turn(int x,int y)
{
    if(map[x][y]=='w')
        map[x][y]='b';
    else
        map[x][y]='w';
    for(int i=0;i<4;i++)
    {
        int tx=x+nextt[i][0];
        int ty=y+nextt[i][1];
        if(tx<0||ty<0||tx>=4||ty>=4)
            continue;
        if(map[tx][ty]!='w')
            map[tx][ty]='w';
        else
            map[tx][ty]='b';
    }
}
void dfs(int x,int y,int step)
{
    if(step>min1)
        return ;
    if(F())
    {
        min1=min(min1,step);
        return ;
    }
    if(x==4)
        return ;
    turn(x,y);
    if(y>=3)
       dfs(x+1,0,step+1);
    else
        dfs(x,y+1,step+1);
    turn(x,y);
    if(y>=3)
        dfs(x+1,0,step);
    else
        dfs(x,y+1,step);
}
int main()
{
    for(int i=0;i<4;i++)
        scanf("%s",map[i]);
    min1=9999999;
    dfs(0,0,0);
    if(min1>16)
        printf("Impossible\n");
    else
        printf("%d\n",min1);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值