ZOJ 3872:Beauty of Array【数列】

Beauty of Array

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input
3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2
Sample Output
105
21
38
题意:给你一个数列,让你求它的所有连续子序列中的不同值的和;
AC-code:
#include<cstdio>
#include<cstring>
#define LL unsigned long long
using namespace std;
int vis[1000005],last[1000005];
int main()
{
	int T,n,i;
	LL sum,a;
	scanf("%d",&T);
	while(T--)
	{
		memset(vis,0,sizeof(vis));
		memset(last,0,sizeof(last));
		scanf("%d",&n);
		sum=0;
		for(i=0;i<n;i++)
		{
			scanf("%llu",&a);
			if(!vis[a])
			{
				sum=sum+(1+i)*(n-i)*a;
				vis[a]=1;
				last[a]=i;
			}
			else
			{
				sum=sum+(i-last[a])*(n-i)*a;
				last[a]=i;
			    //vist[a]=1;
			}
		}
		printf("%llu\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值