ZOJ3872:Beauty of Array(浙江省赛2015)

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.
Input

    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

    The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.
Output

    For each case, print the answer in one line.
Sample Input

    3
    5
    1 2 3 4 5
    3
    2 3 3
    4
    2 3 3 2

Sample Output

    105
    21
    38


 此题属于序列dp和LIS有异曲同工之妙。(看了题解才恍然大悟,唉)

下面给出AC代码

#include<cstdio>
#include<cstring>
using namespace std;
#define  LL long long
int pre[1000005];
LL dp[100005];
int main(){
    int t,n;
    scanf("%d",&t);
    while(t--){
        LL sum = 0,num;
        memset(pre,0,sizeof(pre));
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%lld",&num);
            dp[i]=dp[i-1]+num*(i-pre[num]);///int * int = int 结果可能溢出 此题数据比较水 num 不改成long long 也能过
            pre[num]=i;
        }
        for(int i=1;i<=n;i++) sum+=dp[i];
        printf("%lld\n",sum);
    }
}


第一次发表博客,就快大二了,现在还是个非常菜的菜鸟,如有说的不对的地方,请各位大神多多指教。


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值