ZOJ 3870:Team Formation【技巧】

Team Formation

Time Limit: 3 Seconds       Memory Limit: 131072 KB

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{AB}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input
2
3
1 2 3
5
1 2 3 4 5
Sample Output
1
6
思路:
对于一个数,如果我们把x的二进制表示中最高位的0变成1,0前面的都不变,那么得到的这个新值肯定比x大。即:如果x的第i位为1(i为x的最高位的1所在位置),y的第i位为0(i不是y的最高位所在位置),那么z=x^y之后,z > max(x, y)。
AC-code:
#include<cstdio>
#include<cstring>
using namespace std;
int b[32];
int a[100005];
void check(int x)
{
	int l=31;
	while(l>=0)
	{
		if(x&(1<<l))
		{
			b[l]++;
			return ;
		}
		l--;
	}
}
int main()
{
	int T,n,i;
	long long sum;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		memset(b,0,sizeof(b));
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			check(a[i]);
		 } 
		 sum=0;
		 for(i=0;i<n;i++)
		 {
		 	int l=31;
		 	while(l>=0)
		 	{
		 		if(a[i]&(1<<l))
		 			break;
		 		l--;
			 }
			 while(l>=0)
			 {
			 	if(!(a[i]&(1<<l)))
			 	{
			 		sum+=b[l];
				 }
				 l--;
			 }
		 }
		 printf("%lld\n",sum);
	}
	return 0;
 } 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值