ZOJ-1151 单词逆序

1151:将一行中的单词全部逆序输出

Sample Input

1

3
I am happy today
To be or not to be
I want to win the practice contest


Sample Output

I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc


简单题。由于不知道一行到底有多少,整体读完一行再分词处理有可能溢出。
因此采用流处理形式,来一点处理一点,立即输出。用数组缓存单个词,遇到空格或换行就逆序输出。


#include<stdio.h>
#include<iostream>
using namespace std;

int main()
{
int N;
int n;
char word[100];
char c;
int i;

cin>>N;
while(N--)
{
cin>>n;
getchar(); //读掉末尾的换行符
while(n--)
{
i=0;
while(1)
{
c=getchar();
if(c=='\n'||c==' ') //单词末尾
{
for(int k=i-1;k>=0;k--)
printf("%c",word[k]);
printf("%c",c);
i=0;
}
else
{
word[i++]=c;
}

if(c=='\n')
break;
}
}
if(N!=0)
printf("\n");
}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值