ZOJ_1151

ZOJ_1151: Word Reversal

Time Limit: 2000 MS   Memory Limit: 64 MB   64bit IO Format: %lld

[ Submit][ Status][ Web Board]

Description

For each list of words, output a line with each word reversed without changing the order of the words.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.

Output

For each test case, print the output on one line.

Sample Input 

1
3
I am happy today
To be or not to be
I want to win the practice contest

Sample Output

I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc

Source

East Central North America 1999, Practice


大水题,但是留意  stringstream和getline的相关用法,这样子写的话很方便。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<sstream>
using namespace std;


int n;
const int N=1000006;
string ss,tmp;
int main()
{
    int T;
    scanf("%d",&T);
    int ff=0;
    while(T--)
    {
        if(ff)
            puts("");
        ff=1;
      scanf("%d",&n);
      getchar();
      for(int i=0;i<n;i++)
      {
         getline(cin,ss);
        stringstream buff(ss);
        int flag=0;
        while(buff>>tmp)
        {
            if(flag)
                 printf(" ");
            int len=tmp.length();
            for(int i=len-1;i>=0;i--)
            {


                printf("%c",tmp[i]);
            }


            flag=1;
        }
        puts("");






      }


    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值