PAT (Advanced Level) Practice 1055 The World‘s Richest (25 分) 凌宸1642

PAT (Advanced Level) Practice 1055 The World’s Richest (25 分) 凌宸1642

题目描述:

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

译:福布斯杂志每年都会根据世界上最富有的人的年度排名发布亿万富翁名单。 现在你应该模拟这个工作,但只关注某个年龄段的人。 也就是说,给定 N 个人的净资产,你必须找出他们年龄范围内最富有的 M 个人。


Input Specification (输入说明):

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤105) - the total number of people, and K (≤103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−106,106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space…

译:每个输入文件包含一个测试用例,对于每个测试用例第一行包含 2 个正整数 :N (≤105) -总人数, K (≤103) -查询总数 。接下来 N 行,每行包含一个人的姓名(不超过 8 个字符且没有空格的字符串) , 年龄( (0, 200] 之间的整数) ,实际财富( [−106,106] 的整数) 。最后有 K 行查询,每行包含 3 个正整数:M (≤100) -输出的最大人数, 和表示年龄区间的 [Amin, Amax] 。所有在一行中的数字都会被空格隔开。


Output Specification (输出说明):

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

译:对于每个查询,第一行中输出 Case #X: 其中X 表示从 1 开始的查询编号。 接下来输出 M 个在年龄区间 [Amin, Amax] 内的最富有的人。 每个人的信息占一行,格式如下:

Name Age Net_Worth

输出顺序为他们实际财富的非递增顺序。这种情况下存在相同的实际财富值,则按照年龄的非递减序列输出。如果实际财富和年龄都相同,那么必须按照名字的字典序的非递减顺序输出。题目保证不存在 3 个信息都相同的两个人。如果这种情况下没有找到,则输出 None


Sample Input (样例输入):

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output (样例输出):

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

The Idea:

  • 常规的对结构体进行 sort 排序
  • 排序有三条规则,首先是财富值的多少,然后是年龄的大小,最后是名字的字典序。
  • 输出的时候,要判断年龄区间,并且要统计输出的人数,保证不超过最大允许输出人数 M 。如果没有人满足要求,则输出 None

The Codes:

#include<bits/stdc++.h>
using namespace std ;
struct Peo{
	string name ;
	int age , worth ;
};
bool cmp(Peo a , Peo b){
	if(a.worth != b.worth) return a.worth > b.worth ;
	else if(a.age != b.age) return a.age < b.age ;
	return a.name < b.name ;
}
int n , k , m , amin , amax ;
int main(){
	scanf("%d %d" , &n , &k) ;
	Peo peo[n] ;
	for(int i = 0 ; i < n ; i ++){
		cin >> peo[i].name >> peo[i].age >> peo[i].worth ;
	}
	sort(peo , peo + n , cmp) ;
	for(int i = 1 ; i <= k ; i ++){
		scanf("%d %d %d" , &m , &amin , &amax) ;
		printf("Case #%d:\n" , i) ;
		int cnt = 0 ;
		for(int j = 0; j < n && cnt < m; j ++){
			if(peo[j].age >= amin && peo[j].age <= amax){
				printf("%s %d %d\n", peo[j].name.c_str(), peo[j].age, peo[j].worth) ;
				cnt ++ ;
			}
		}
		if(!cnt) printf("None\n") ;
	}
	return 0 ;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

lingchen0522

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值