【笨方法学PAT】1016 Phone Bills (25 分)

一、题目

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

二、题目大意

给定每个人的通话记录,求每个人的花费。

三、考点

排序

四、注意

1、“时间戳”思维,将时间和金额都转化为时间戳的形式;

2、先按照人名和时间排序;

3、之后按照on-line、off-line对数据进行清洗;

4、计算每个人的金额,输出;这里也可以使用map<string, vector<node> >

五、代码

#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
using namespace std;
struct node {
	string name;
	bool status;
	int month;
	int d, h, m;
	int timestamp;
};

int c[24];
int total_num = 0;

bool cmp(node n1,node n2) {
	if (n1.name != n2.name)
		return n1.name < n2.name;
	else
		return n1.timestamp < n2.timestamp;
}

float getMoney(int d, int h, int m) {
	double money = 0.0;
	//day
	money = d *1.0 * total_num * 60;
	//hour
	for (int i = 0; i < h; ++i) {
		money += 1.0*c[i] * 60;
	}
	//minutes
	money += 1.0 * c[h] * m;
	return money / 100;
}

int main() {
	//read
	for (int i = 0; i < 24; ++i) {
		cin >> c[i];
		total_num += c[i];
	}
		
	int n;
	cin >> n;
	vector<node> vec;
	for (int i = 0; i < n; ++i) {
		node tmp;
		string s;
		cin >> tmp.name;
		scanf("%d:%d:%d:%d", &tmp.month, &tmp.d, &tmp.h, &tmp.m);
		cin >> s;
		if (s == "on-line")
			tmp.status = 0;
		else
			tmp.status = 1;
		//change to timestamp
		tmp.timestamp = tmp.d * 60* 24 + tmp.h * 60 + tmp.m;
		vec.push_back(tmp);
	}

	//sort
	sort(vec.begin(), vec.end(), cmp);

	//clear status
	int i = 0;
	vector<node> vec_clear;
	while (i + 1 < vec.size()) {
		if (vec[i].name == vec[i + 1].name&&vec[i].status == 0 && vec[i + 1].status == 1) {
			vec_clear.push_back(vec[i]);
			vec_clear.push_back(vec[i + 1]);
			i += 2;
		}
		else
			i++;
	}

	//solve every one
	string s;
	for (int i = 0; i + 1 < vec_clear.size(); ) {
		//new body
		if (vec_clear[i].name != s) {
			printf("%s %02d\n", vec_clear[i].name.c_str(), vec_clear[i].month);
			s = vec_clear[i].name;
		}

		//every record
		double total = 0.0;
		while (i + 1 < vec_clear.size()&&vec_clear[i].name == s) {
			//get minutes
			int min = vec_clear[i + 1].timestamp - vec_clear[i].timestamp;
			
			//get money
			double money = 0.0;
			money = getMoney(vec_clear[i + 1].d, vec_clear[i + 1].h, vec_clear[i + 1].m) - getMoney(vec_clear[i].d, vec_clear[i].h, vec_clear[i].m);
			total += money;

			printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2lf\n", vec_clear[i].d, vec_clear[i].h, vec_clear[i].m,
				vec_clear[i + 1].d, vec_clear[i + 1].h, vec_clear[i + 1].m, min,money);
			i += 2;
		}

		printf("Total amount: $%.2lf\n", total);
	}

	system("pause");
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值