hdu 3006 The Number of set 状态压缩

用一个二进制数表示一个集合 如 {1,4,7} 可以用   1001001,每个位置上有0或1代表这个数存在不存在;

用"|"可以实现两个集合的合并。

The Number of set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1264    Accepted Submission(s): 770


Problem Description
Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.
 

Input
There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.
 

Output
For each case,the output contain only one integer,the number of the different sets you get.
 

Sample Input
  
  
4 4 1 1 1 2 1 3 1 4 2 4 3 1 2 3 4 1 2 3 4
 

Sample Output
  
  
15 2

#include <stdio.h>
#include <string.h>
int main()
{
	int n, m, k, w, t, i, ans;
	int set[1<<14];
	while(~scanf("%d%d", &n, &m))
	{
		memset(set,0,sizeof(set));
		while(n--)
		{
			scanf("%d", &k);
			w = 0;
			while(k--)
			{
				scanf("%d", &t);
				w += 1<< (t-1);
			}
			set[w] = 1;
			for(i = 1;i < 1<<14;i++)
			{
				if(set[i])
					set[w|i] = 1;
			}
			ans = 0;
		}
		for(i = 1;i < 1<<14;i++)
		{
			if(set[i])
				ans++;
		}
		printf("%d\n", ans);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值