暑假集训第二周——贪心 L - 生物碰撞


L - 生物碰撞
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together. 

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000
分析

即给你一定的生物,他们会有一定的重量,如果他们相互碰撞,
那么根据题目给的那个公式2*sqrt(m1*m2) ,质量会减少。

这个公式表示的是两个物品质量分别为m1和m2,而他们碰撞后的总质量会减少为2*sqrt(m1*m2)

给你一定的这样的生物及它们的质量,要你求它们经过碰撞后的最小总质量。

这题也是一个排序处理的问题,只不过比较复杂,不多说,分析题意

思路:
就是把最大的先组合,一个优先队列解决,优先对列就是最大的优先使用

本题就是优先取出两个大的,然后处理以后再放进队列继续排,此时队列长度就少于1了

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
#include<cstdio>
#include<queue>
#include<cmath>
#include<algorithm>
using namespace std;
int main(){
  priority_queue<double>q;
  int n;
  double a,b,c;
  while(~scanf("%d",&n)){
    while(!q.empty())
      q.pop();
    for(int i=0;i<n;i++){
      scanf("%lf",&a);
      q.push(a);
    }
    while(q.size()>1){
      a=q.top(); q.pop();
      b=q.top(); q.pop();
      c=2*sqrt(a*b);
      q.push(c);
    }
    printf("%.3f\n",q.top());
  }
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值