Sicily 1001. Alphacode

1001. Alphacode

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Alice and Bob need to send secret messages to each other and are discussing ways to encode their messages: Alice: "Let's just use a very simple code: We'll assign `A' the code word 1, `B' will be 2, and so on down to `Z' being assigned 26." Bob: "That's a stupid code, Alice. Suppose I send you the word `BEAN' encoded as 25114. You could decode that in many different ways!" Alice: "Sure you could, but what words would you get? Other than `BEAN', you'd get `BEAAD', `YAAD', `YAN', `YKD' and `BEKD'. I think you would be able to figure out the correct decoding. And why would you send me the word `BEAN' anyway?" Bob: "OK, maybe that's a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense." Alice: "How many different decodings?" Bob: "Jillions!" For some reason, Alice is still unconvinced by Bob's argument, so she requires a program that will determine how many decodings there can be for a given string using her code.

Input

Input will consist of multiple input sets. Each set will consist of a single line of digits representing a valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits. An input line of `0' will terminate the input and should not be processed

Output

For each input set, output the number of possible decodings for the input string. All answers will be within the range of a long variable.

Sample Input

25114
1111111111
3333333333
0

Sample Output

6
89
1
 

题意解析:
1到26分别代表字母A~Z,那么12可以理解为AB,也可以理解为第12个字母L.给出一串数字,如25114,问一共有多少种不同的理解.上述的问题的答案是6种,分别是`BEAN‘, `BEAAD’, `YAAD‘, `YAN’, `YKD‘ 和 `BEKD'.
思路:用动态规划,对于每个特定位置si,要么是xxx+(si),要么是xxx+(si-1si).
 状态:dp[i]表示数字串s[1…i]有dp[i]种不同的理解
 状态转移:当s[i]=='0'时,dp[i]=dp[i-2];
当s[i]!='0'时,如果s[i-1]s[i]组成的数大于26或小于10,dp[i] = dp[i-1],
如果组成的数处于10~26之间,dp[i] = dp[i-1]+dp[i-2]


(DP真心不会,到现在都没找到思考的切入点,每次做DP题都没信心没思路,此代码也是参考了网上大神的思路写出来的,唉。。神赐我一道闪电打通潜藏我身体的DP二脉吧=。=)


代码如下:
#include<iostream>
#include<string>
using namespace std;

int dp[100010];

int main()
{
    string s;
    while(cin>>s&&s!="0")
    {
        int len=s.size();
        for(int i=0;i<len;i++)
            dp[i]=0;
        
        dp[0]=1;    
        for(int i=1;i<len;i++)
        {
            if(s[i]=='0')
            {
                if(i==1)
                    dp[i]=dp[i-1];
                else
                    dp[i]=dp[i-2];
            }
            else{
                    if((s[i-1]=='1'&&s[i]<='9')||(s[i-1]=='2'&&s[i]<='6'&&s[i]>'0'))
                    {
                         if(i==1)dp[i]=dp[i-1]+1;
                         else
                             dp[i]=dp[i-1]+dp[i-2];
                     }
                     else
                         dp[i]=dp[i-1];
            }
                    
        }
        cout<<dp[len-1]<<endl;
    }
    return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值