Family Property

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 ... Childk M_estate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi's are the ID's of his/her children;M_estate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG_sets AVG_area

where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000

5551 4 0.750 100.000

本来用并交集来写的,结果好复杂,还有bug,去网上搜了结果用 dfs 简单多了。。。

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
#include<cmath>
#include<queue>
using namespace std;

#define maxn 10000

struct node{
	int id;
	int num;
	double est;
	double area;
	node(int id=0, int num=0,double est=0,double area=0):id(id),num(num),est(est),area(area){}
}p[maxn];
int e[maxn],ar[maxn],f[maxn];
int id,num;
double est,area;
vector<int> t[maxn];

bool cmp(node a,node b){
if(a.area!=b.area)
		return a.area>b.area;
	return a.id<b.id;
}
void dfs(int x)
{
	id=min(id,x);
	f[x]=0;
	num++;
	est+=e[x];
	area+=ar[x];
	for(int i=0;i<t[x].size();i++){
		if(f[t[x][i]]==1)
			dfs(t[x][i]);
	}
}
int main() {
	int a;
	cin >> a;
	int total=0;
	for(int i=0;i<a;i++){
		int x,y,z;
		scanf("%d %d %d",&x,&y,&z);
		f[x]=1;
		if(y!=-1){
			f[y]=1;
			t[x].push_back(y);
			t[y].push_back(x);
		}
		if(z!=-1){
			f[z]=1;
			t[x].push_back(z);
		    t[z].push_back(x);
		}
		int b;
		scanf("%d",&b);
		for(int j=0;j<b;j++){
			scanf("%d",&z);
			f[z]=1;
			t[x].push_back(z);
		    t[z].push_back(x);
		}
		int c,d;
		scanf("%d %d",&c,&d);
		e[x]=c;
		ar[x]=d;
	}
	for(int i=0;i<10000;i++){
		if(f[i]!=1)
			continue;
		id=10000;num=0;est=0;area=0;
		dfs(i);
	    p[total++]=node(id,num,est/(double)num,area/(double)num);
	}
	sort(p,p+total,cmp);
	printf("%d\n",total);
	for (int i = 0; i < total; i++)
	    {
	        printf("%04d %d %.3lf %.3lf\n", p[i].id, p[i].num, p[i].est, p[i].area);
	    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值