HDU 1098 Ignatius's puzzle

Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that  ,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

 

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 

Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 

Sample Input
  
  
11 100 9999
 

Sample Output
  
  
22 no 43
 

Author
eddy
 
题意:给定一个k,请找出a的值。使 :f(x)=5*x^13+13*x^5+k*a*x对于x取任何值都可以被65 整除;
利用数学归纳法和二项式定理来证明:

f(x+1 ) = f (x) +  5*( (13  1 ) x^12 ...... .....+(13  13) x^0  )+  13*(  (5  1 )x^4+...........+ ( 5  5  )x^0  )+k*a;

很容易证明,除了5*(13  13) x^0 、13*( 5  5  )x^0 和k*a三项以外,其余各项都能被65整除.
那么也只要求出18+k*a能被65整除就可以了.
而f(1)也正好等于18+k*a

所以,只要找到a,使得18+k*a能被65整除,也就解决了这个题目.
 

 假设存在这个数a,因为对于任意x方程都成立,所以,当x=1时f(x)=18+ka;有因为f(x)能被65整出,这可得出f(x)=n*65;

即:18+ka=n*65;若该方程有整数解则说明假设成立。

 

ax+by = c的方程有解的一个充要条件是:c%gcd(a, b) == 0。

 然后枚举直到65*n-18%k == 0为止。

#include<stdio.h>
int main()
{
    int k;
    while(scanf("%d",&k)!=EOF)
    {
        int i;
        for(i=1;i<=65;i++)
        {
            if((18+k*i)%65==0)
            {
                printf("%d\n",i);
                break;
            }
        }
        if(i>65)
        printf("no\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值