自测05—Shuffling Machine(自动洗牌机)

题目:

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

大致题意:自动洗牌机,牌一开始按照顺序依次排放,输入一个number表示要洗牌的次数(repeat),输入一个order(一串数字),即洗牌的规则。假设总共有5张牌S3, H5, C1, D13 and J2,输入order为{4, 2, 5, 3, 1},表示第1张牌移到第4个位置,第二个移到第2个位置,第三个移到第5个位置……//自己题目意思也理解了好久啊……

思考:本来还在想因为要保存中间过程,是不是能用栈来保存。但是发现没有后进先出。所以直接用多维数组了。

#include<iostream>

using namespace std;
#define N 20
#define MAXC 54

int main()
{

    string ori[]={"S1","S2","S3","S4","S5","S6",
                "S7","S8","S9","S10","S11","S12","S13",
                "H1","H2","H3","H4","H5","H6",
                "H7","H8","H9","H10","H11","H12","H13",
                "C1","C2","C3","C4","C5","C6",
                "C7","C8","C9","C10","C11","C12","C13",
                "D1","D2","D3","D4","D5","D6",
                "D7","D8","D9","D10","D11","D12","D13",
                "J1","J2"};



    int k,exchange[MAXC];
    cin>>k;
    for(int i=0;i<MAXC;i++){
        cin>>exchange[i];
    }


//创建多维数组,用来保存中间的变化过程

    string (*p)[MAXC];
    p=new string[k][MAXC]();
    for(int i=0,temp;i<k;i++){
        for(int j=0;j<MAXC;j++){
          if(i==0){
            temp=exchange[j];
            p[i][temp-1]=ori[j];//注意temp要减1,因为数组下标和位置差1——这里调试了好久——调试的时候MAXC可以取小一点
          }
          else{
            temp=exchange[j];
            p[i][temp-1]=p[i-1][j];
          }
        }
    }

    k--;
    for(int i=0;i<MAXC;i++){
        if(i==MAXC-1){
            cout<<p[k][i]<<endl;
        }
        else
            cout<<p[k][i]<<" ";
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值