poj 1852 Ants

Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 21692 Accepted: 8902

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207 

这道题看起来挺简单,第一个想法就是直接暴力?但是每个蚂蚁都有两种朝向,n只就是2^n,如果n大了铁定T了啊。所以暴力还是不行。

那就再看看题呗。

怎么最快呢?就是每个蚂蚁都向自己离得最近的那个端点走是最快的,这样遍历一遍就可以求出最短时间了;

怎么最长呢?先想想两个蚂蚁相遇的情况,速度一样,又不分哪只蚂蚁,所以我们可以把他们看成直接穿过去了也未尝不可,那么每只蚂蚁就是独立的了。所以想求出最长时间,求蚂蚁到竿子端点的最大距离不就得了,就让他走最长的路。再遍历一次求出最长时间就可以了。

代码:

#include <stdio.h>

#define MAX 100010

int min(int x,int y)

{

if(x>y) return y;

else if(x<y) return x;

else if(x=y) return x;

}

int max(int x,int y)

{

if(x>y) return x;

else if(x<y) return y;

else if(x=y) return y;

}

int main ()

{

int t,l,n;

scanf("%d",&t);

while(t--)

{

int x[MAX]={0};

scanf("%d %d",&l,&n);

for(int i=0;i<n;i++) scanf("%d",&x[i]);

int minT = 0;

for(int i=0;i<n;i++) minT = max(minT,min(x[i],l-x[i]));

int maxT = 0;

for(int i=0;i<n;i++) maxT = max(maxT,max(x[i],l-x[i]));

printf("%d %d\n",minT,maxT);

}

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值