hdu 4803 (想法题 卡精度)

题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=4803

Poor Warehouse Keeper

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1493    Accepted Submission(s): 428


Problem Description
Jenny is a warehouse keeper. He writes down the entry records everyday. The record is shown on a screen, as follow:

There are only two buttons on the screen. Pressing the button in the first line once increases the number on the first line by 1. The cost per unit remains untouched. For the screen above, after the button in the first line is pressed, the screen will be:

The exact total price is 7.5, but on the screen, only the integral part 7 is shown.
Pressing the button in the second line once increases the number on the second line by 1. The number in the first line remains untouched. For the screen above, after the button in the second line is pressed, the screen will be:

Remember the exact total price is 8.5, but on the screen, only the integral part 8 is shown.
A new record will be like the following:

At that moment, the total price is exact 1.0.
Jenny expects a final screen in form of:

Where x and y are previously given.
What’s the minimal number of pressing of buttons Jenny needs to achieve his goal?
 

Input
There are several (about 50, 000) test cases, please process till EOF.
Each test case contains one line with two integers x(1 <= x <= 10) and y(1 <= y <= 10 9) separated by a single space - the expected number shown on the screen in the end.
 

Output
For each test case, print the minimal number of pressing of the buttons, or “-1”(without quotes) if there’s no way to achieve his goal.
 

Sample Input
  
  
1 1 3 8 9 31
 

Sample Output
  
  
0 5 11
Hint
For the second test case, one way to achieve is: (1, 1) -> (1, 2) -> (2, 4) -> (2, 5) -> (3, 7.5) -> (3, 8.5)

把上面那个按钮 称为按钮1;

下面那个按钮  称为按钮2;


题意:两种操作,如果按下按钮1,会使数量+1,单价不变,总价=(数量+1)*单价

           如果按下按钮2,会使总价加1,数量不变,单价=(总价+1)/数量;

现在问至少多少步可以使得   按钮1数字为x, 按钮2数字为y;


思路:(1)由题意容易知道至少 需要 x-1步(按上面的按钮);

            (2)最后可以转化为单价的问题,给定x,y后,不论按哪个按钮,单价只会呈现上身趋势,并且达到最大,那么就由最大的单价倒着推出每两次按下按钮1之间按下按钮2次数的最大值(贪心)


#include <iostream>
#include <string.h>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstdio>
#include <algorithm>

typedef long long ll;
const double eps=1e-5;
using namespace std;

int main()
{
    double x,y;
    while(scanf("%lf%lf",&x,&y)!=EOF)
    {
      if(x>y)
      {
        cout<<-1<<endl;
        continue;
      }

      double s=(y+1-eps)/x;
      int cnt=(int)x-1;

      double tmp=1;
      for(int i=1;i<=(int)x;i++)
      {
        int t=(int)(s*i-tmp);
        tmp+=t;
        cnt+=t;
        tmp=tmp/i*(i+1);
      }

     printf("%d\n",cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值