1009 Product of Polynomials (25 分)

1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

以下转载自https://www.cnblogs.com/549294286/p/3571573.html,侵删。

题目描述:

给定两个多项式的系数和指数, 算着两个多项式的乘积.

算法分析:

思路1:map保存项

用map保存项,计算结果需要剔除map项值==0的项。

思路2:hash保存项

注意点:

用map保存项,结果需要剔除map项值==0的项。

 

map

复制代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <map>

using namespace std;

int main()
{
    int K, L;
    map<int,double> m1,m2,mp;
    scanf("%d", &K);
    for (int i=0; i<K; i++){
        int e;double c;
        scanf("%d%lf", &e, &c);
        m1[e] = c;
    }
    scanf("%d", &L);
    for (int i=0; i<L; i++) {
        int e;double c;
        scanf("%d%lf", &e, &c);
        m2[e] = c;
    }

    map<int,double>::iterator it1,it2,it;
    for (it1=m1.begin(); it1!=m1.end(); it1++) {
        for (it2=m2.begin(); it2!=m2.end(); it2++) {
            int key = it1->first + it2->first;
            double value = it1->second * it2->second;
            it = mp.find(key);
            if (it == mp.end()) {
                mp[key] = value;
            }
            else {
                it->second += value;
            }
        }
    }
    for(it=mp.begin(); it!=mp.end();) {
        if (it->second == 0.0) {
            mp.erase(it++);
        }
        else it++;
    }
    printf("%d", mp.size());
    map<int,double>::reverse_iterator rit;
    for (rit=mp.rbegin(); rit!=mp.rend(); rit++) {
        printf(" %d %.1lf", rit->first, rit->second);
    }
    return 0;
}

复制代码

 

hash

复制代码

#include<cstdio>
#include<cstring>

#define MAXN 2001
double hash[MAXN],hash1[MAXN];

int main(){
    freopen("in.txt","r",stdin);
    int n1,n2,i,j,k;
    double tmp;
    //scanf("%d",&n1);
    while(scanf("%d",&n1)!=EOF){
        memset(hash,0,sizeof(hash));
        memset(hash1,0,sizeof(hash1));
        for(i=0;i<n1;i++){
            scanf("%d%lf",&k,&tmp);
            hash1[k]=tmp;
        }
        scanf("%d",&n2);
        for(i=0;i<n2;i++){
            scanf("%d%lf",&k,&tmp);
            for(j=1000;j>=0;j--){
                hash[j+k]+=hash1[j]*tmp;
            }
        }
        int count=0;
        for(i=0;i<MAXN;i++){
            if(hash[i]!=0) count++;
        }
        if(count==0) printf("0\n");
        else{
            printf("%d",count);
            for(i=MAXN-1;i>=0;i--){
                if(hash[i]!=0) printf(" %d %.1lf",i,hash[i]);
            }
            printf("\n");
        }
    }
    return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值