[HDU1260]-Tickets

Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
 

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
 

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
 

Sample Input
  
  
2 2 20 25 40 1 8
 
Sample Output
  
  
08:00:40 am 08:00:08 am
题目描述:Jesus希望用最短的时间把ticket卖完,他找到了一些规律:卖单人票时,卖给K个人,每个人会花费衣服
定时间Si, 相邻的两人可以买双人票,K-1个数据代表的是相互两个人买双人票时花费的时间。现在希望你来帮助
Jesus花费最短的时间把票卖 完。
解题思路:此题是简单DP,状态转移方程的出发点是选单人票还是双人票,针对dp[i],当前加进来第i张票,
你只有两种选择, 1:选择现在的单人票single[i],或者选择i和i-1之间的双人票adjacent[i-1],那么通过
以上推理相信你也相出了状态转移 方程。dp[i]=min(dp[i-1]+single[i],dp[i-2]+adjacent[i-1]);
code如下:
#include <cstdio>
#include <cstring>
#include <iomanip>
#include <cmath>
#include <cstdlib>
#include <iostream>
#include <string>
#include <set>
#include <map>
#include <stack>
#include <list>
#include <utility>
#include <vector>
#include <algorithm>
#include <queue>
using namespace std;
typedef __int64 LL;
const double PI = acos(-1);
const double eps = 1e-8;
const int INF = 0x3f3f3f3f;
const int MAXM = 1000000;
const int MAXN = 20000+10;
const int MOD = 1000000007;
template<typename T>
inline T minn(T a,T b,T c){return (a=(a>b)?b:a)>c?c:a;}
template<typename T>
inline T maxx(T a,T b,T c){return (a=(a>b)?a:b)>c?a:c;}
#define CLR(a,b) memset((a),(b),sizeof(a))
int single[MAXN];//每个人买单人票花费的时间
int adjacent[MAXN];//相互两个人买双人票的时间
int dp[MAXN*10];
int main()
{
	int n;
	ios::sync_with_stdio(false);
	while(cin >> n)
	{
		while(n --)
		{
			int m;
			cin >> m;
			for(int i = 1;i <= m;++ i)
				cin >> single[i];
			if(m==1)//如果只有一张票,直接输出结果
			{
				printf("08:00:%02d am\n",single[1]);
				continue;
			}
			for(int i = 1;i < m;++ i)
				cin >> adjacent[i];
			memset(dp,0,sizeof(dp));
			dp[1]=single[1];//将dp[1]初始化为第一个single花费的时间
			for(int i = 2;i <= m;++ i)//到底选择双人票还是选择单人票
				dp[i]=min(dp[i-1]+single[i],dp[i-2]+adjacent[i-1]);
			int sumTime=dp[m];
			int second = sumTime%60;//得到秒钟s
			int minute = sumTime/60%60;//得到分钟min
			int hours = sumTime/3600+8;//得到时钟hour
			string str;//存储am,pm
			if(hours>12||(hours==4&&(second!=0||minute!=0)))
				str="pm";
			else
				str="am";
			hours = (hours>12)?hours:hours%12;
			printf("%02d:%02d:%02d %s\n",hours,minute,second,str.c_str());
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值