文章链接http://poj.org/problem?id=1458
Common Subsequence
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 48657 | Accepted: 20064 |
Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x
ij= zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab programming contest abcd mnp
Sample Output
4 2 0
Source
这道题是水体,可以作为熟练代码用的LCS,除了输入要处理一下,别的没了
代码如下:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cctype>
#define MAXN 720
using namespace std;
int main()
{
string bck;
while(getline(cin,bck))
{
string s,t;
int dp[MAXN][MAXN];
memset(dp,0,sizeof(dp));
int ct = 0,len_bck = bck.length();
while(isalpha(bck[ct]) && ct<len_bck) s += bck[ct++];
while(!isalpha(bck[ct]) && ct<len_bck) ct++;
while(isalpha(bck[ct]) && ct<len_bck) t += bck[ct++];
int len_s = s.length(),len_t = t.length();
for(int i=0;i<len_s;i++)
{
for(int j=0;j<len_t;j++)
{
if(s[i] == t[j]) dp[i+1][j+1] = dp[i][j] + 1;
else dp[i+1][j+1] = max(dp[i+1][j],dp[i][j+1]);
}
}
printf("%d\n",dp[len_s][len_t]);
}
return 0;
}