[POJ_1125]Stockbroker Grapevine

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 30330 Accepted: 16579

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

题意 : 

1. 有N个股票经纪人,需要通过他们进行信息操作(消息传递)。

2. 信息在股票经理人之前传递需要花费一定的时间。

要求 :

选择起点,是的消息传递时间最短,并求出最短时间

思路 : 

典型的弗洛伊德算法,计算有向图的最短路径,关于Floyd可以参考度娘的百科

如例一,如下有向图


根据FLOYD算法,对于3个端点,有4个状态,分别是初始状态A0 , 先后分别插入1, 2,3节点之后的A1 ,A2,A3状态,如下表

A0

1

2

3

1

0

4

5

2

2

0

6

3

2

2

0


A1

1

2

3

1

0

4

5

2

2

0

min(6,2+5)

3

2

min(2,2+4)

0


A2

1

2

3

1

0

4

min(5,4+6)

2

2

0

6

3

min(2,2+2)

2

0


A3

1

2

3

1

0

min(4,5+2)

5

2

min(2,6+2)

0

6

3

2

2

0


A3为最终状态,可以得到最短时间是通过“3”的2min,当然,3个节点就有3+1个状态,N个节点就有N+1种状态,只要不断建模得出最后一种状态,那最短路径就迎刃而解了,下面是代码~

//POJ 1125
#include<stdio.h>
#define Max 0xffffff

int main()
{
	int cont,no,mi,cnt,min,imax,shr;
	int i,j,k,l;
	int map[101][101];
	scanf("%d",&cont); //联系人个数
	while(cont)
	{ 
		for(i = 1; i <= cont; i++)
			for(j = 1; j <= cont; j++)
			{
				if(i == j) map[i][j] = 0;
				else 
					map[i][j] = Max;
			}

		for(k = 1; k <= cont; k++)
		{
			scanf("%d",&cnt);   //cnt为当前联系人相邻联系人的个数
			for(l = 0; l < cnt; l++)
			{
				scanf("%d%d",&no,&mi);  //no为联系人编号 还有对应传递时间
				map[k][no] = mi;         //建图
			}
		}

		//弗洛伊德算法
		for(k = 1; k <= cont; k++)      // k 为 途径节点
			for(i = 1; i <= cont; i++)
				for(j = 1; j <= cont; j++)
					if(map[i][j] > map[i][k]+map[k][j])
						map[i][j] = map[i][k]+map[k][j]; //取最小值

		min = Max;
		for(i = 1; i <= cont; i++)
		{
			imax = 0;   //每一行的最大值
			for(j = 1; j <= cont; j++)
				if(map[i][j] > imax) imax = map[i][j];  

			if(imax < min)
			{
				min = imax;
				shr = i;
			}
		}
		if(min == Max)
			printf("disjoint\n");
		else
			printf("%d %d\n",shr,min);

		scanf("%d",&cont);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值