HDU 2717 Catch That Cow(bfs)

77 篇文章 0 订阅
5 篇文章 0 订阅

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12933    Accepted Submission(s): 3991


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

分析:被这种输入描述坑两回了,没提示说多组示例输入,可就是多组示例。。WA了5次
一个bfs题目,开始用dfs,但搜索的时间太慢,bfs搜索出来的就是最少的次数。其中有一些判断是否越界的判断。

代码如下:

#include <stdio.h>
#include <queue>
#include <string.h>
#define INF 100010
using namespace std;
int n,k;
int ans[INF*2];
struct node{
	int x,t;
};
queue <node> q;

void init()
{
	while(!q.empty())
		q.pop();
	memset(ans,0,sizeof(ans));
}

int judge(node m){
	
	if(m.x>=0 && m.x<=100000 && !ans[m.x])
		return 1;
	return 0;
}

int bfs(int x)
{
	node tmp;
	tmp.x=x;
	tmp.t=0;
	ans[tmp.x]=1;
	q.push(tmp);
	while(!q.empty())
	{
		tmp = q.front();
		q.pop();
		if(tmp.x==k)
			return tmp.t;
		node m;
		m.t=tmp.t+1;
		
		m.x=tmp.x-1;
		if(judge(m))
		{
			ans[m.x]=1;
			q.push(m);
		}
		
		m.x=tmp.x+1;
		if(judge(m))
		{
			ans[m.x]=1;
			q.push(m);
		}
		
		m.x=tmp.x*2;
		if(judge(m))
		{
			ans[m.x]=1;
			q.push(m);
		}
	}
}

int main()
{
	int i,j;
	while(~scanf("%d %d",&n,&k))
	{
		init();
		printf("%d\n",bfs(n));
	}

	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值