uva 12083 Guardian of Decency (二分图匹配)

uva 12083 Guardian of Decency

Description
Frank N. Stein is a very conservative high-school teacher. He wants to take some of his students on an excursion, but he is afraid that some of them might become couples. While you can never exclude this possibility, he has made some rules that he thinks indicates a low probability two persons will become a couple:

Their height differs by more than 40 cm.
They are of the same sex.
Their preferred music style is different.
Their favourite sport is the same (they are likely to be fans of different teams and that would result in fighting). 

So, for any two persons that he brings on the excursion, they must satisfy at least one of the requirements above. Help him find the maximum number of persons he can take, given their vital information.

Input
The first line of the input consists of an integer T ≤ 100 giving the number of test cases. The first line of each test case consists of an integer N ≤ 500 giving the number of pupils. Next there will be one line for each pupil consisting of four space-separated data items:

an integer h giving the height in cm;
a character 'F' for female or 'M' for male;
a string describing the preferred music style;
a string with the name of the favourite sport. 

No string in the input will contain more than 100 characters, nor will any string contain any whitespace.

Output
For each test case in the input there should be one line with an integer giving the maximum number of eligible pupils.

Sample Input

2
4
35 M classicism programming
0 M baroque skiing
43 M baroque chess
30 F baroque soccer
8
27 M romance programming
194 F baroque programming
67 M baroque ping-pong
51 M classicism programming
80 M classicism Paintball
35 M baroque ping-pong
39 F romance ping-pong
110 M romance Paintball

Sample Output

3
7

题目大意:Frank是一个思想有些保守的老师。有一次,他需要带一些学生出去旅游,但又怕其中有一些学生在旅途中萌生爱意。为了降低这种事情发生的概率,他决定确保带出去的任意两个学生至少要满足下面4条中的一条:
1)身高相差大于40厘米。
2)性别相同。
3)最喜欢的音乐属于不同的类型。
4)最喜欢的体育比赛相同。
你的任务是帮助Frank挑选尽量多的学生,使得任意两个学生至少满足上述条件中的一条。
解题思路:将可以匹配的男女建边,然后就是一个二分图匹配问题。最后用n减去求出的最大的匹配,就是答案。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
using namespace std;

typedef long long ll;
const int N = 505;
const int M = 250005;
struct Node {  
    int height, id;  
    char sex[5], music[105], sport[105];  
}stu[N];  
int n, e, ans;
int head[N], pnt[M], Next[M], rec[N];  
bool S[N], T[N];  

void init() {
    e = 0;  
    memset(head, -1, sizeof(head));  
    memset(rec, 0, sizeof(rec));  
    ans = 0;
}

bool check(int i,int j) {  
    if(abs(stu[i].height - stu[j].height) > 40) return false;  
    //身高差超过40cm
    if (strcmp(stu[i].music, stu[j].music)) return false;
    //喜欢的音乐类型相同
    if (!strcmp(stu[i].sport, stu[j].sport)) return false;
    //喜欢的体育类型不同
    return true;  
}

void addEdge(int u,int v) {  
    pnt[e] = v;
    Next[e] = head[u];
    head[u] = e++;  
}  

void input() {
    scanf("%d", &n);  
    for(int i = 1; i <= n; i++) { 
        scanf("%d %s %s %s", &stu[i].height, stu[i].sex, stu[i].music, stu[i].sport);  
    }
    for(int i = 1; i <= n; i++) {  
        if(stu[i].sex[0] == 'F') continue; //边只能从男生到女生 
        for(int j = 1; j <= n; j++) {
            //将可以匹配的男女建边
            if(stu[j].sex[0] == 'F' && check(i,j)) addEdge(i,j);  
        }
    }
}

bool match(int u) {  
    S[u] = 1;  
    for(int i = head[u]; i != -1 ; i = Next[i])  
        if(!T[pnt[i]]) {  
            T[pnt[i]] = 1;  
            if(!rec[pnt[i]] || match(rec[pnt[i]])) {  
                rec[pnt[i]] = u;  
                return true;  
            }  
        }  
    return false;  
}  

void hungary() {
    for(int i = 1; i <= n; i++) {  
        memset(S, 0, sizeof(S));  
        memset(T, 0, sizeof(T));  
        if(match(i)) ans++;  
    }
}

int main() {  
    int T;
    scanf("%d", &T);  
    while(T--) {  
        init();
        input();
        hungary();
        printf("%d\n", n - ans);  
    }  
    return 0;  
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
用代码解决这个问题The program committee of the school programming contests, which are often held at the Ural State University, is a big, joyful, and united team. In fact, they are so united that the time spent together at the university is not enough for them, so they often visit each other at their homes. In addition, they are quite athletic and like walking. Once the guardian of the traditions of the sports programming at the Ural State University decided that the members of the program committee spent too much time walking from home to home. They could have spent that time inventing and preparing new problems instead. To prove that, he wanted to calculate the average distance that the members of the program committee walked when they visited each other. The guardian took a map of Yekaterinburg, marked the houses of all the members of the program committee there, and wrote down their coordinates. However, there were so many coordinates that he wasn't able to solve that problem and asked for your help. The city of Yekaterinburg is a rectangle with the sides parallel to the coordinate axes. All the streets stretch from east to west or from north to south through the whole city, from one end to the other. The house of each member of the program committee is located strictly at the intersection of two orthogonal streets. It is known that all the members of the program committee walk only along the streets, because it is more pleasant to walk on sidewalks than on small courtyard paths. Of course, when walking from one house to another, they always choose the shortest way. All the members of the program committee visit each other equally often. Input The first line contains the number n of members of the program committee (2 ≤ n ≤ 105). The i-th of the following n lines contains space-separated coordinates xi, yi of the house of the i-th member of the program committee (1 ≤ xi, yi ≤ 106). All coordinates are integers. Output Output the average distance, rounded down to an integer, that a member of the program committee walks from his house to the house of his colleague.
05-26

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值