T - 20

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 
题意:
有1*1,2*2,3*3,4*4,5*5,6*6的箱子,装到6*6的箱子里最少要多少个这样的箱子

分析:

6*6,5*5,4*4每种这样的箱子占一个大箱子,4个3*3的箱子占一个大箱子,2*2的可以放在跟4*4放在一起,也可以跟3*3的放在一起,1*1的可以放在有空的任意地方

代码:

#include<iostream>
using namespace std;
int main()
{
    int i,as,t,a2,a1,a[7];
    while(1)
    {
        as=t=0;
        for(i=1;i<7;as+=a[i],i++)
            cin>>a[i];
        if(as==0)
            break;
        t=a[5]+a[4]+a[6]+(a[3]+3)/4;
        if(a[3]%4)
        a2=(3-a[3]%4)*2+1+a[4]*5;
        else
        a2=a[4]*5;
        if(a[2]>a2)
        t+=(a[2]-a2+8)/9;
        a1=(t-a[6])*36-a[5]*25-a[4]*16-a[3]*9-a[2]*4;
        if(a[1]>a1)
            t+=(a[1]-a1+35)/36;
        cout<<t<<endl;
    }
}
感受:

看着麻烦,理清楚就好做了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值