G - 07

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题意:
从位置n到位置k有两种走路方式,一种是直接到达2*n处,一种是到达n-1或n+1处,问最少走几步

分析:

用广搜,先找到的就是最短的步数

代码:

#include<iostream>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
int k,b[100005];
struct num
{
    int n,s;
};
void bfs(int t)
{
    queue<num>v;
    num d,f;
    d.n=t;
    d.s=0;
    v.push(d);
    while(!v.empty())
    {
        d=v.front();
        if(d.n==k)
        {
            cout<<d.s<<endl;
            return;
        }
        v.pop();
        if(d.n-1>=0&&!b[d.n-1])
        {
            b[d.n-1]=1;
            f.n=d.n-1;
            f.s=d.s+1;
            v.push(f);
        }
        if(d.n+1<=100000&&!b[d.n+1])
        {
            b[d.n+1]=1;
            f.n=d.n+1;
            f.s=d.s+1;
            v.push(f);
        }
        if(d.n*2<=100000&&!b[d.n*2])
        {
            b[d.n*2]=1;
            f.n=d.n*2;
            f.s=d.s+1;
            v.push(f);
        }
    }
}
int main()
{
    memset(b,0,sizeof(b));
    int n;
    cin>>n>>k;
    if(n>=k)
        cout<<n-k<<endl;
    else
        bfs(n);
}

感受:

套用模板就行,不用思考的。。。。哈哈

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值