Q - 17

Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 


 

Input

n (0 < n < 20). 
 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
 

Sample Input

       
       
6 8
 

Sample Output

       
       
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

题意:

n个数从1到n,构成一个环形,保证相邻的两个数和为素数,找到所有的可能

分析:

其实用dfs就可以,要特殊处理第一个数和第n个数

代码:

#include<iostream>
#include<cstring>
#include<string>
using namespace std;
int a[25],b[25],n,ss[40];
void dfs(int k)
{
    int i,j;
    if(k==n){
        if(ss[a[k]+a[1]]==0)
        {
            for(j=1;j<n;j++)
            cout<<a[j]<<" ";
            cout<<a[n]<<endl;
        }
        return;
    }
    for(i=2;i<=n;i++)
    {
        if(b[i]==0)
        {
            if(ss[i+a[k]]==0&&k<n){
                b[i]=1;
                a[k+1]=i;
                dfs(k+1);
            }
            b[i]=0;
        }
    }
}
int main()
{
    int i,j;
    ss[1]=1;
    a[1]=1;
    for(i=2;i<40;i++)
    {
        if(ss[i]==0)
        {
            for(j=i+1;j<40;j++)
            if(j%i==0)
            ss[j]=1;
        }
    }
    i=1;
    while(cin>>n&&n)
    {
        memset(b,0,sizeof(b));
        cout<<"Case "<<i<<":"<<endl;
        if(n==1)cout<<1<<endl;
        else
        dfs(1);
        cout<<endl;
        i++;
    }
}

感受:

挺简单的,只不过要注意输出形式,不然容易多空格

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值