B - 02

 

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

题意:

 

遍历方格,输出字典序最小的方案

分析:

就是能往上走就往上走,不行就往下走

代码:

 

#include<iostream>
#include<cstring>
#include<cmath>
#include<stdio.h>
using namespace std;
struct num
{
    int x, y;
};
int a[29][29],b[16]={-1,-2,1,-2,-2,-1,2,-1,-2,1,2,1,-1,2,1,2},p,q,ff;
num v[65];
void dfs(int k,int l,int s)
{
    int i,j;
    if(ff==1)return;
    if(s==q*p)
    {
        for(i=0;i<s;i++)
            cout<<char(v[i].y+'A'-1)<<v[i].x;
            cout<<endl;
            ff=1;
    }
    else
    {
        for(i=0;i<16;i+=2)
        {
            if(k+b[i]>=1&&k+b[i]<=p&&l+b[i+1]>=1&&l+b[i+1]<=q&&!a[k+b[i]][l+b[i+1]])
            {
                v[s].x=k+b[i];
                v[s].y=l+b[i+1];
                a[k+b[i]][l+b[i+1]]=1;
                dfs(k+b[i],l+b[i+1],s+1);
                a[k+b[i]][l+b[i+1]]=0;
            }
        }
    }return;
}
int main()
{
    int i,j,k,t;
    scanf("%d",&t);
    v[0].x=1;
    v[0].y=1;
    for(k=1;k<=t;k++)
    {
        cout<<"Scenario #"<<k<<":"<<endl;
        scanf("%d%d",&p,&q);
        ff=0;
        memset(a,0,sizeof(a));
        a[1][1]=1;
        dfs(1,1,1);
        if(ff==0)cout<<"impossible"<<endl;
        cout<<endl;
    }
}

 

 

 

感受:

这个题wrong 了好多遍就是没有看到字典序。。。没毛病,眼睛越来越瞎了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值