Uva 10341 — Solve It

Solve the equation:
        p*e-xq*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
        where 0 <= x <= 1.

Input

Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: pqrst and u (where 0 <= p,r<= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.

Output

For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.

Sample Input

0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1

Sample Output

0.7071
No solution
0.7554
 
题意:解方程,求出令上述方程为零的根;
分析:观察方程可知,右边部分为单调递减函数,所以可以二分查找函数,需注意数值精度
 
 
#include<stdio.h>
#include<string.h>
#include<math.h>
#define epsx 1e-7
#define e   2.718281828459

int p,q,r,s,t,u;
double search(double a,double b)
{
    double m=(a+b)/2;
    if(b-a<epsx)return m;
    
    double g=p*pow(e,-m)+ q*sin(m) + r*cos(m) + s*tan(m) + t*m*m + u;
    if(g==0)
        return m;
    if(g>0)
        return search(m,b);
    if(g<0)
        return search(a,m);
}

int main()
{
    while(scanf("%d%d%d%d%d%d",&p,&q,&r,&s,&t,&u)!=EOF)
    {
        if(p*pow(e,-0)+ q*sin(0) + r*cos(0) + s*tan(0) + t*0*0 + u<0||p*pow(e,-1)+ q*sin(1) + r*cos(1) + s*tan(1) + t*1*1 + u>0)
        {   printf("No solution\n");continue; }
            
        else
            printf("%.4lf\n",search(0,1));
    }
    return 0;
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值