UVaOJ10341 - Solve It

10341 - Solve It

Time limit: 3.000 seconds

Solve the equation:
        p*e-x q*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
        where 0 <= x <= 1.

Input

Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: pqrstand u (where 0 <= p,r <= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.

Output

For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.

Sample Input

0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1

Sample Output

0.7071
No solution
0.7554
 
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

double p, q, r, s, t, u;

double f(double x) {
    double temp;
    temp = p * exp(-x) + q * sin(x) + r * cos(x) + s * tan(x) + t * x * x + u;
    return temp;
}
int main() {
    while (scanf("%lf%lf%lf%lf%lf%lf", &p, &q, &r, &s, &t, &u) != EOF) {
        double high = 1.0, low = 0.0, mid;
        for (int i = 0; i < 100; i ++) {
            mid = (high + low) / 2;
            if (f(mid) > 0) {
                low = mid;
            } else {
                high = mid;
            }
        }
        if (fabs(f(mid) - 0.0) < 1e-8) {
            printf("%.4lf\n", mid);
        } else {
            printf("No solution\n");
        }
    }
    return 0;
}


 
 

Mustaq Ahmed

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值