poj 3259 Wormholes 【判断负环】

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 36810 Accepted: 13485

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
 
 
 
题意:有n个点,m条路,路是无向的,w个虫洞,虫洞是单向的,虫洞可以使时间倒流,问那个人会不会看到没有出发前的自己。
 
 
代码: spfa
 
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
#define INF 0x3f3f3f
#define MAXN 1000+10
#define MAXM 6000+10 //数组开大些;不然会RE; 
using namespace std;
struct record
{
	int to,val,next;
}edge[MAXM];
int low[MAXN],vis[MAXN],head[MAXN],used[MAXN];//used记录该点被用几次; 
int n,m,w,top;
void init() //初始化; 
{
	top=0;
	for(int i=1;i<=n;i++)
	{
		head[i]=-1;
		vis[i]=0;
		used[i]=0;
	}
}
void add(int a,int b,int c)
{
	edge[top].to=b;
	edge[top].val=c;
	edge[top].next=head[a];
	head[a]=top++;
}
void spfa()
{
	int i;
	queue<int>q;
	for(i=1;i<=n;i++)
	{
		low[i]=INF;
	}
	while(!q.empty())
	{
		q.pop();
	}
	vis[1]=1;
	low[1]=0;
	used[1]++;
	q.push(1);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=0;
		for(i=head[u];i!=-1;i=edge[i].next)
		{
			int v=edge[i].to;
			if(low[v]>low[u]+edge[i].val)
			{
				low[v]=low[u]+edge[i].val;
				if(!vis[v])
				{
					vis[v]=1;
					used[v]++; //每用一次加1; 
					if(used[v]>n) //如果被用过的次数已经超过了总节点数,说明已出现负环; 
					{
						printf("YES\n");
						return ;
					}
					q.push(v);
				}
			}
		}
	}
	printf("NO\n");
}
int main()
{
	int F,a,b,c,s,e,t;
	scanf("%d",&F);
	while(F--) //数据组数; 
	{
		scanf("%d%d%d",&n,&m,&w);//n节点的数量,m路的数量,w虫洞的数量; 
		init();
		while(m--)
		{
			scanf("%d%d%d",&a,&b,&c);
			add(a,b,c); //路是双向的; 
			add(b,a,c);
		}
		while(w--)
		{
			scanf("%d%d%d",&s,&e,&t);
			add(s,e,-t); //虫洞是单向的; 
		}
		spfa();
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值