POJ - 2185 - Milking Grid

9 篇文章 0 订阅
Milking Grid
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 8998 Accepted: 3919

Description

Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns. 

Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below. 

Input

* Line 1: Two space-separated integers: R and C 

* Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow's breed. Each of the R input lines has C characters with no space or other intervening character. 

Output

* Line 1: The area of the smallest unit from which the grid is formed 

Sample Input

2 5
ABABA
ABABA

Sample Output

2

Hint

The entire milking grid can be constructed from repetitions of the pattern 'AB'.

问 能够通过不断复制获取 所给矩阵的 最小 矩阵 的面积

本题测试数据比较水。提供一组数据。

Input

2 8
ABCDEFAB
ABCDEABC
2 8
ABCDEFAB
AAAABAAA

Output

16
12

hash+kmp的next数组运用


#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
char b[10008][80];
int kmp_next[10008],n,m;
unsigned int a[10008];
void KMP_next(int tt)
{
    int i=0,j=-1;
    kmp_next[0]=-1;
    while(i<tt)
        if(j==-1||a[i]==a[j])
            kmp_next[++i]=++j;
        else
            j=kmp_next[j];
}
unsigned int ELFHash(char* str, unsigned int len)
{
    unsigned int hash = 0;
    unsigned int x    = 0;
    unsigned int i    = 0;
    for(i = 0; i < len; str++, i++)
    {
        hash = (hash << 4) + (*str);
        if((x = hash & 0xF0000000L) != 0)
        {
            hash ^= (x >> 24);
        }
        hash &= ~x;
    }
    return hash;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        int x,y,ans;
        for(int i=0; i<n; i++)
        {
            scanf("%s",b[i]);
            a[i]=ELFHash(b[i],strlen(b[i]));
        }
        KMP_next(n);
        ans=n-kmp_next[n];
        for(int i=0; i<m; i++)
        {
            char temp[10008];
            for(int j=0; j<n; j++)
                temp[j]=b[j][i];
            a[i]=ELFHash(temp,strlen(temp));
        }
        KMP_next(m);
        cout<<ans*(m-kmp_next[m])<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值