1039 Course List for Student (25分)【散列+vector的使用】

1039 Course List for Student (25分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

解题思路:

有N个学生K门课,先给定我们选择每门课的学生姓名,并在之后给出N个学生的姓名,要求我们按顺序给出每个学生的选课情况。

注意:这里学生的名字是按字符串给出,而课程是按序号给出。所以很多人一拿到题目会想使用map去实现,但是很遗憾,我们使用map和string时在最后一个测试点会超时。因此本题只能使用字符串hash来求解。

这里我们先来补充一下字符串hash的相关知识(前提先得知道整数的hash):

假设字符串均由大写字母A~Z构成。在此基础上不妨把A~Z看成0~25,这样就可以将26个大写字母对应到二十六进制中。然后我们按照二十六进制转十进制的思路进行转换。这样我们由进制转换的结论可以得知,在进制转换的过程中,得到的十进制是唯一的,由此便可以实现将字符串映射为整数的需求(注意:转换成的整数最大值是26^{len}-1,其中的len为字符串的长度)。代码如下:

int hashFunc(char S[], int len)
{
    int id = 0;
    for(int i = 0;i<len;i++)
    {
        id = id*26 + (S[i] - 'A');
    }
    return id;
}

本题代码:(注意不要用cin和cout,会超时)

#include<iostream>
#include<vector>
#include<algorithm>
#include<string.h>
using namespace std;
#define N 40010
#define maxn 26*26*26*10+1

vector<int> courses[maxn];

int hashFunc(char name[])
{
	int id = 0;
	for (int i = 0; i < 3; i++)
	{
		id = id * 26 + (name[i] - 'A');
	}
	id = id * 10 + (name[3] - '0');
	return id;
}

int main()
{
	char name[5];
	int n, k;
	scanf("%d%d", &n, &k);
	for (int i = 0; i < k; i++)
	{
		int course, x;
		scanf("%d%d", &course, &x);
		for (int j = 0; j < x; j++)
		{
			scanf("%s", name);
			int id = hashFunc(name);
			courses[id].push_back(course);
		}
	}
	for (int i = 0; i < n; i++)
	{
		scanf("%s", name);
		int id = hashFunc(name);
		sort(courses[id].begin(), courses[id].end());
		printf("%s %d", name, courses[id].size());
		for (int j = 0; j < courses[id].size(); j++)
		{
			printf(" %d", courses[id][j]);
		}
		printf("\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值