ZOJ-1457Prime Ring Problem(搜索)

Prime Ring Problem

--------------------------------------------------------------------------------

Time Limit: 10 Seconds      Memory Limit: 32768 KB

--------------------------------------------------------------------------------

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 


Input

n (0 < n < 20)


Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.


Sample Input

6
8


Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2


标准深搜 ,很郁闷的超时,结果原来是没处理单数,还PE了两次,真是郁闷
*/
#include <iostream>
using namespace std;
int cir[21];           
int table[40]={0,1,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,1};
int num;
int x[21];
int n,ca;

void dfs(int i)
{
 if(i==n+1)
 {
  if(table[cir[1]+cir[n]])
  { 
   for(int i=1;i<n;++i)
    cout<<cir[i]<<" ";
   cout<<cir[n]<<endl;
  }
  return;
 }
 
 for(int j=2;j<=n;++j)
  if(!x[j]&&table[j+cir[i-1]])
  {
   cir[i]=j;
   x[j]=1;
   dfs(i+1);
   cir[i]=0;
   x[j]=0;
  }
}

int main()
{
 ca=0;
 while(cin>>n)
 {
  
  ++ca;
  cir[1]=1;
  x[1]=1;
  num=2;
  cout<<"Case "<<ca<<":"<<endl;
  if(n%2==0)
   dfs(2);
  cout<<endl;
 }
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值