PAT 甲级 1045 Favorite Color Stripe

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L(≤10​4​​ ) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

题目大意:本题是根据给出喜欢的颜色序列,然后给出一段颜色序列,要求求出按照喜欢的颜色序列顺序所能得到最大的序列长度。
解题思路: 本题可按照基本的动态规划思路(最长不下降序列)来做。首先将喜欢的颜色按照顺序映射到hashtable,之后读入给定的序列若hashtable[num]!=0说明是喜欢的颜色,将该颜色在给定的喜欢颜色中对应的下标即hashtable[num]放入数组color中。之后就是求数组color的最长不下降子序列。

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxv = 10010;
int main(void){
	int N,L,M,hashtable[maxv] = {0},color[maxv],dp[maxv];
	scanf("%d %d",&N,&M);
	for(int i = 1;i <= M;i++){
		int num;
		scanf("%d",&num);
		hashtable[num] = i;
	}
	scanf("%d",&L);
	int length = 0;
	for(int i = 0;i < L;i++){
		int num;
		scanf("%d",&num);
		if(hashtable[num]!=0){
			color[length++] = hashtable[num];
		}
	}
	int ans = -1;
	for(int i = 0;i < length;i++){
		dp[i] = 1;
		for(int j = 0;j < i;j++){
			if(color[i] >= color[j] && dp[j] + 1 > dp[i]){
				dp[i] = dp[j] + 1;
			}
		}
		ans = max(ans,dp[i]);
	}
	printf("%d",ans);
	return 0;
}

还可以通过LCS最长公共子序列的基本递推方式来做不过本题公共子序列中的元素是可以重复的所以有所不同

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxv = 10010;
const int maxc = 210;
int dp[maxc][maxv],A[maxc],B[maxv];
int main(void){
	int n,m;
	scanf("%d%d",&n,&m);
	for(int i = 1;i <= m;i++){
		scanf("%d",&A[i]);
	}
	int L;
	scanf("%d",&L);
	for(int i = 1;i <= L;i++){
		scanf("%d",&B[i]);
	}
	for(int i = 0;i <= m;i++){
		dp[i][0] = 0;
	}
	for(int j = 0;j <= L;j++){
		dp[0][j] = 0;
	}
	for(int i = 1;i <=m;i++){
		for(int j = 1;j <= L;j++){
			int MAX = max(dp[i - 1][j],dp[i][j - 1]);
			if(A[i] == B[j])
				dp[i][j] = MAX + 1;
			else
				dp[i][j] = MAX;
		}
	}
	printf("%d",dp[m][L]);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值