PAT甲级:1045 Favorite Color Stripe

题目描述:

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤104) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

题目大意: 

给定a, b字符串,求出a b两个字符串公共子序列的最大长度。其中a子序列中的某个数字可以按照自身的顺序在公共子序列中出现多次。

解题思路: 

动态规划

状态 dp[i][j] 的集合位对于a前i个数字和b前j个数字所有的公共子序列,其值代表这些子序列的长度最大值。
状态转移方式和最长公共子序列问题类似,考虑a的第i个数字以及b的第j个数字是否在子序列中出现分为四种情况进行讨论。

不同的是,对于第i个数字和第j个数字同时出现在子序列的情况,由于a中的数字可以在公子序列中出现多次,当满足b[j] == a[i]时,状态dp[i][j]由dp[i][j - 1]转移而来。

Python3代码: 

import sys
N = int(input())
lst1 = list(map(int,sys.stdin.readline().split()))
M = lst1[0] ; lst1 = [0] + lst1[1:]
lst2 = list(map(int,sys.stdin.readline().split()))
L = lst2[0] ; lst2 = [0] + lst2[1:]

dp = [[0]*(L+10) for i in range(M+10)]
for i in range(1,M+1) :
    for j in range(1,L+1) :
        dp[i][j] = dp[i-1][j-1]
        dp[i][j] = max(dp[i][j],dp[i-1][j],dp[i][j-1])
        if lst1[i] == lst2[j] : dp[i][j] = max(dp[i][j],dp[i][j-1]+1)

print(dp[M][L])

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

UESTC_KS

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值