An Easy Task
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 16217 Accepted Submission(s): 10363
Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?
Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.
Note: if year Y is a leap year, then the 1st leap year is year Y.
Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.
Note: if year Y is a leap year, then the 1st leap year is year Y.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
Each test case contains two positive integers Y and N(1<=N<=10000).
Output
For each test case, you should output the Nth leap year from year Y.
Sample Input
3 2005 25 1855 12 2004 10000
Sample Output
2108 1904 43236HintWe call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.
Author
Ignatius.L
#include<iostream>
using namespace std;
int main()
{
int T;
int Y,N;
cin>>T;
while(T--)
{
int number=0;int i;
cin>>Y>>N;
for( i=Y;;i++)
{
if(number==N)
break;
else
if(((i%4==0)&&(i%100!=0))||(i%400==0))
number++;
}
cout<<i-1<<endl;
}
return 0;
}