杭电 HDU ACM 1003 Max Sum



Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 164592    Accepted Submission(s): 38540


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 


水题 不愿意 连续刷了 ,改换算法题。
第一个题目就从dp下了手,感觉第一次不太好理解。

分析找出了状态转移方程d【i】=max{d[i-1]+a[i],a[i]};  意思是以第i个元素结尾的子序列的值或着a【i】两者的最大值为d【i】值。并在状态转移的过程中时刻更新各个状态d【i】中的最大值那么每一个d【i】都是以i结尾的子序列最大值,因为a【i】如果加上与前一个元素i-1结尾的子序列最大值d【i-1】,那么为了使d【i】最大,如果a【i】+d【i-1】是大于0的那么必然要加上,否则还不如不加,还么a【i】大呢,注意temp的作用。标记的是每次起始位置,而不是最大连续段值的起始,一旦发现后面又产生了更大的连续字段和,则把他
更新给s。
AC:
#include<iostream>
using namespace std;
int main()
{

    int n,T,num,sum,maxn,s,e,temp;int t=0;
    cin>>T;
    while(T--)
    {
        sum=0;
        maxn=-101;
        s=e=temp=1;
        cin>>n;

        for(int i=1;i<=n;i++)
        {
            cin>>num;
            sum+=num;
            if(sum>maxn)
                {
                    maxn=sum;
                    e=i;
                    s=temp;

                }
                else if(sum<0)
                {
                    sum=0;
                   temp=i+1;

                }
        }

        cout<<"Case "<<++t<<":"<<endl
        <<maxn<<" "<<s<<" "<<e<<endl;
        if(T)
            cout<<endl;

    }

    return 0;
}

这个代码 不知道怎么记录位置 以后在解决

现在我终于又回来了 ,今天是八月31号,偶然又碰到他,想当年怎么都理解不了的东西想在想想真容易,其实我一直也没刷过dp,但是就是智慧在无形中随着时间增长了。
再贴一发:
/*=============================================================================
#
#      Author: liangshu - cbam 
#
#      QQ : 756029571 
#
#      School : 哈尔滨理工大学 
#
#      Last modified: 2015-08-31 18:41
#
#     Filename: A.cpp
#
#     Description: 
#        The people who are crazy enough to think they can change the world, are the ones who do ! 
=============================================================================*/
#
#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
const int INF = 100003;
int cnt[INF];
int dp[INF];
int main(){
    int t;cin>>t;
    int cs = 1;
    while(t--){
        int n;
        cin>>n;
        for(int i = 0; i < n; i++){
            scanf("%d",&cnt[i]);
        }
        memset(dp, 0 , sizeof(dp));
        dp[0] = cnt[0];
        for(int i = 1; i < n; i++){
            dp[i] = dp[i - 1] >= 0 ? dp[i - 1] + cnt[i] : cnt[i];
        }
        int loc1 = 0,loc2 = 0,M = dp[0];
        for(int i = 1; i < n; i++){
            if(dp[i] > M){
                M = dp[i];
                loc1 = i;
            }
        }
        loc2 = loc1;
        for(int x = loc2; x >= 0; x--){
            if(dp[x] >= 0){
                    loc2= x;
                    
            } 
            else break;
        }
        cout<<"Case "<<cs++<<":\n";
        cout<<M<<" "<<loc2 + 1<<" "<<loc1 + 1<<endl;
        if(t)cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值