poj2442---Sequence

2 篇文章 0 订阅
Sequence
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 8342 Accepted: 2732


给一个m*n的矩阵;从每行选出一个求前m小的元素;(矩阵元素可重复使用)

思路:一致保持前m小;

Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4

Source

POJ Monthly,Guang Lin
#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<stack>
#include<cmath>
#include<algorithm>
#include<map>
#include<string>
using namespace std;
int a[2010];
int main()
{
    int t,n,m,x;
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            priority_queue<int>Q;
            scanf("%d%d",&n,&m);
            for(int i=0; i<n; i++)
            {
                if(i==0)
                {
                    for(int j=0; j<m; j++)
                    {
                        scanf("%d",&x);
                        Q.push(x);
                    }
                }
                else
                {
                    for(int j=0; j<m; j++)
                    {
                        a[j]=Q.top();
                        Q.pop();
                    }
                    for(int j=0; j<m; j++)
                    {
                        scanf("%d",&x);
                        for(int k=m-1; k>=0; k--)
                        {
                            if(j==0)
                            {
                                Q.push(x+a[k]);

                            }
                            else
                            {
                                if(x+a[k]<=Q.top())
                                    {
                                        Q.push(x+a[k]);
                                        Q.pop();
                                    }
                                    else
                                        break;
                            }
                        }
                    }
                }
            }
            for(int i=0; i<m; i++)
            {
                a[i]=Q.top();
                Q.pop();
            }
            for(int i=m-1; i>=0; i--)
            {
                printf("%d",a[i]);
                if(i!=0)
                    printf(" ");
                else
                    printf("\n");
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值