poj 2377 无向图的最大生成树

http://vjudge.net/contest/view.action?cid=48211#problem/E

Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

Hint

OUTPUT DETAILS: 

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.
这道题是求最大生成树,其实如果这道题放在一周前我也不会做==

想想和最大费用最大流和最小费用最大流关系一样,我们在求最大生成树的时候只需要把题目中给出的所有权边去相反数,然后利用最小生成树的kruskal算法,将结果取相反数就是答案

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
struct note
{
    int start;
    int end;
    int w;
}edge[20005];
int pa[20005];
int n,m,k,p;
bool cmp(note a,note b)
{
    if(a.w<b.w)
        return true;
    return false;
}
void make_set()
{
    for(int i=0;i<=p;i++)
        pa[i]=i;
}
int find(int x)
{
    if(x!=pa[x])
        return pa[x]=find(pa[x]);
    return pa[x];
}
int kruskal()
{
    int i,ans=0;
    make_set();
    sort(edge,edge+p,cmp);
    for(i=0;i<p;i++)
    {
        int x=find(edge[i].start);
        int y=find(edge[i].end);
        if(x!=y)
        {
            pa[y]=x;
            ans+=edge[i].w;
        }
    }
    return ans;
}
int main()
{
    int x,y,z;
    while(~scanf("%d%d",&n,&m))
    {
        p=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            edge[p].start=x;
            edge[p].end=y;
            edge[p++].w=-z;
        }
        int ans=-kruskal();
        int sum=0;
        for(int i=1;i<=n;i++)
            if(pa[i]==i)
                sum++;
        //printf("%d\n",sum);
        if(sum==1)
           printf("%d\n",ans);
        else
           printf("-1\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值