ACM-DP之Max Sum——hdu1003

之前去忙齐鲁软件大赛了,好久没有更新CSDN了,

现在忙完了,继续ACM生活。。

今天做了一道动态规划的题目:


Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 116583    Accepted Submission(s): 27023


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6




//*******************************************************
//*  程 序 名:hdu_1003.cpp								*
//*														*
//*  作    者:Tree										*
//*														*
//*  编制时间:2013年9月27日							*
//*														*
//*  主要功能:hdu 1003 Max Sum							*
//*														*
//*******************************************************

/*
	思路:
		这是一道动态规划(DP)的题目,求所输入的一组数据中,连续的数组成的和最大,标出这段连续数的起始位置和终止位置,
		大体想法为:  读入一个数temp,之前数字之和为now,判断 now+temp<temp ,是 则代表now为负数看,即不需要从之前位置读,
				可以直接从当前位置读,让first等于当前位置,now等于temp,否 则代表之前为正数,可以让总和最大,now+=temp并
				继续往下读。。。。

 */



#include <iostream>
using namespace std;
int main()
{
	
	int now,temp,max,first,last;				//now为当前数据的和(不算正在读取的数据),temp为所读取的数据,max为最大数据和(所求值),
												//first为开始位置,last为终止位置
	int i,j,n,t,x;								//t为共多少组数据,n为每组数据个数,i为循环变量,j为Case输出准备,x临时记录起始位置
	
	
	cin>>t;

	for(j=1;j<=t;++j)
	{
		cin>>n>>temp;
		
		first=last=x=1;
		now=max=temp;
		

		for(i=2;i<=n;++i)
		{
			cin>>temp;
			if(now+temp<temp)
			{
				now=temp;
				x=i;
			}
			else
				now+=temp;
			if(now>max)
			{
				max=now;
				first=x;
				last=i;
			}
		}

		
		cout<<"Case "<<j<<":"<<endl<<max<<" "<<first<<" "<<last<<endl;
		
		if(j!=t)							// 题目中的格式要求,每个Case间要有空行,最后一个case后没有空行
			cout<<endl;
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值